Project

General

Profile

Bug #193

Lose mails when mailbox is inaccessible

Added by Mavka _no_ over 8 years ago. Updated 2 months ago.

Status:
Closed
Priority:
Normal
Category:
Sylpheed
Target version:
Start date:
04/03/2014
Due date:
% Done:

0%

Estimated time:

Description

Critical regression from 3.3.

Process:
1. Sylpheed check pop3 server
2. See new mail
3. Receive it
4. Delete mail from server
5. Try to save mail in mailbox
6. If mailbox is inaccessible, then mail lose permanently.

Program have to check possibility of write before step 4.

Try to create mailbox on pendrive and remove it.

#1

Updated by Hiroyuki Yamamoto over 8 years ago

Mavka no wrote:

Critical regression from 3.3.

Process:
1. Sylpheed check pop3 server
2. See new mail
3. Receive it
4. Delete mail from server
5. Try to save mail in mailbox
6. If mailbox is inaccessible, then mail lose permanently.

Program have to check possibility of write before step 4.

Try to create mailbox on pendrive and remove it.

Please provide the following information:

- Platform (Windows/Linux etc., 32/64-bit, version)
- Exact operation
/Message/Receive (normal POP3 incorporation), or /Message/Receive/Remote mailbox (selective POP3 download)

#2

Updated by Hiroyuki Yamamoto over 8 years ago

And please also provide the protocol log when it happened: /Tools/Log window

#3

Updated by Hiroyuki Yamamoto over 8 years ago

  • Status changed from New to In Progress

I have checked the POP3 code, and indeed found the bug you mentioned.
This bug was introduced at 3.4.0beta1.
Fixed at r3375.

I will release 3.4.1 with this fix soon.
Thanks for reporting!

#4

Updated by Hiroyuki Yamamoto over 8 years ago

  • Status changed from In Progress to Resolved
#5

Updated by Hiroyuki Yamamoto over 8 years ago

  • Status changed from Resolved to In Progress

Released 3.4.1.

Remote mailbox seems to have similar problem,
but its deleting of messages requires explicit user operation.
So I'll fix it at the next release.

#6

Updated by Hiroyuki Yamamoto over 8 years ago

  • Priority changed from Immediate to Normal
#7

Updated by Hiroyuki Yamamoto over 8 years ago

  • Status changed from In Progress to Resolved

Also fixed the Remote mailbox at r3396.

#8

Updated by Hiroyuki Yamamoto over 8 years ago

  • Status changed from Resolved to Closed

Completely fixed at 3.4.2.

#9

Updated by boddy massage 6 months ago

We are one of the best body massage service providers in bangalore. Call us for female to male full body massage. We are Offering professional full body massage in bangalore.

http://boddymsg.com/
http://boddymsg.com/services.html
http://boddymsg.com/contact.html
http://boddymsg.com/body_to_body_msg_bang.html
http://boddymsg.com/female_to_male_msg.html
http://boddymsg.com/spa_near_mebang.html
http://boddymsg.com/swedish_msg_bang.html
http://boddymsg.com/ban_msg_center.html
http://boddymsg.com/erotic_msg_bang.html
http://boddymsg.com/hot_stone_massage.html
http://boddymsg.com/full_body_msg.html
http://boddymsg.com/happy_ending_msg.html
http://boddymsg.com/ladies_parlour_me.html
http://boddymsg.com/deep_tissue_msg.html
http://boddymsg.com/female_to_male.html
http://boddymsg.com/body_msg.html
http://boddymsg.com/sensual_msg.html
http://boddymsg.com/body_to_body_spa_nearme.html
http://boddymsg.com/aromatherapy_msg_bang.html
http://boddymsg.com/thai_spa_near_me.html
http://boddymsg.com/nuru_msg_bangalore.html
http://boddymsg.com/msg_center_near_me_bangalore.html
http://boddymsg.com/couples_msg_bang.html
http://boddymsg.com/body_msg_spa_near_me.html
http://boddymsg.com/msg_par_near_me.html
http://boddymsg.com/carn_therapy.html
http://boddymsg.com/msg_spa_near_me.html
http://boddymsg.com/massage_spa.html
http://boddymsg.com/sarjapura.html
http://boddymsg.com/jigani.html
http://boddymsg.com/chandapura.html
http://boddymsg.com/anekal.html
http://boddymsg.com/attibele.html
http://boddymsg.com/madiwala.html
http://boddymsg.com/bommanahalli.html
http://boddymsg.com/yaswanthpur.html
http://boddymsg.com/yelahanka.html
http://boddymsg.com/mathikere.html
http://boddymsg.com/jalahalli.html
http://boddymsg.com/kammanahalli.html
http://boddymsg.com/ramamurthy_nagar.html
http://boddymsg.com/banaswadi.html
http://boddymsg.com/kalyan_nagar.html
http://boddymsg.com/bellundur.html
http://boddymsg.com/sadashivanagar.html
http://boddymsg.com/frazer_town.html
http://boddymsg.com/rajaji_nagar.html
http://boddymsg.com/malleshwaram.html
http://boddymsg.com/jaya_nagar.html
http://boddymsg.com/basavangudi.html
http://boddymsg.com/indira_nagar.html
http://boddymsg.com/KR_Market.html
http://boddymsg.com/KR_Puram.html
http://boddymsg.com/koramangala.html
http://boddymsg.com/marathahalli.html
http://boddymsg.com/bannerghatta_road.html
http://boddymsg.com/hebbal.html
http://boddymsg.com/JP_nagar.html
http://boddymsg.com/HSR_layout.html
http://boddymsg.com/lalbagh.html
http://boddymsg.com/electronic_city.html
http://boddymsg.com/whitfield.html
http://boddymsg.com/brookefield.html
http://boddymsg.com/banashankari.html
http://boddymsg.com/majestic.html
http://boddymsg.com/shivaji_nagar.html
http://boddymsg.com/victoria_layout.html
http://boddymsg.com/jayanagar.html
http://boddymsg.com/all_over_bangalore.html
http://boddymsg.com/bangalore.html
http://boddymsg.com/index.html
http://kamasutramsg.in/
http://kamasutramsg.in/index.html

#10

Updated by seo mind 2 months ago

I have checked this link this is really important for the people to get benefit from. Dot Dot Smile

#11

Updated by seo mind 2 months ago

I adore your websites way of raising the awareness on your readers. Data Dollars Pro

#12

Updated by seo mind 2 months ago

Thanks for your post. I’ve been thinking about writing a very comparable post over the last couple of weeks, I’ll probably keep it short and sweet and link to this instead if thats cool. Thanks. My Traffic Business Review

#13

Updated by seo mind 2 months ago

I was surfing net and fortunately came across this site and found very interesting stuff here. Its really fun to read. I enjoyed a lot. Thanks for sharing this wonderful information. Dot Dot Smile

#14

Updated by seo mind 2 months ago

Nice knowledge gaining article. This post is really the best on this valuable topic. My Traffic Business Review

#15

Updated by seo mind 2 months ago

It proved to be Very helpful to me and I am sure to all the commentators here! My Traffic Business Review

#16

Updated by seo mind 2 months ago

You completed a number of nice points there. I did a search on the issue and found nearly all people will have the same opinion with your blog. Primerica Pyramid Scheme

#17

Updated by seo mind 2 months ago

Great post I would like to thank you for the efforts you have made in writing this interesting and knowledgeable article. Dot Dot Smile

#18

Updated by seo mind 2 months ago

it's really cool blog. Linking is very useful thing.you have really helped Primerica Pyramid Scheme

#19

Updated by seo mind 2 months ago

This is a fabulous post I seen because of offer it. It is really what I expected to see trust in future you will continue in sharing such a mind boggling post Primerica Pyramid Scheme

Also available in: Atom PDF