Project

General

Profile

Bug #165

Layout: Column width/resize issue in folder contents view

Added by Anonymous over 8 years ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Category:
Sylpheed
Target version:
Start date:
01/31/2014
Due date:
% Done:

0%

Estimated time:

Description

I believe that this issue is similar to Bug #160.

Screenshot #1:
When starting Sylpheed with a fresh profile, it opens in a small window and the columns in folder contents view look OK.

Screenshot #2:
When making the window wider, only the last column increases in size, making it unreasonable wide (column "size" on the screenshot). Correcting this manually is not possible, because dragging the border between "date" and "size" to the left only increases the width of the column "date", while the column "size" retains its size. I did not manage to drag the left border of "size" because it is also the window border.

Screenshot #3:
When making the window smaller again, the last column "size" does not change its width. Therefore it extends beyond the window border, making its contents invisible.

Version info:
Sylpheed 3.4.0beta7
Ubuntu 12.04 x64 German


Files

#1

Updated by Anonymous over 8 years ago

Sorry, I made a mistake in my description.

Step 2: "... dragging the border between "date" and "size" to the left -> right ..."

#2

Updated by Hiroyuki Yamamoto about 8 years ago

  • Status changed from New to Confirmed

When making the window wider, only the last column increases in size, making it unreasonable wide (column "size" on the screenshot). Correcting this manually is not possible, because dragging the border between "date" and "size" to the left only increases the width of the column "date", while the column "size" retains its size. I did not manage to drag the left border of "size" because it is also the window border.

Actually, the "right" border of the Size column is draggable.
Because the rightmost column is automatically extended to the window size, it's real (internal) size is not visible.
After dragging the right border of Size, resizing other columns will shrink Size column.

#3

Updated by Hiroyuki Yamamoto about 8 years ago

  • Category set to Sylpheed
  • Status changed from Confirmed to Resolved
  • Assignee set to Hiroyuki Yamamoto

Fixed in r3342 - r3344.

Now Subject column is expanded instead of Size column (requires GTK+ >= 2.14),
and an empty column was added to the right edge to make the resizing of rightmost column easier.

#4

Updated by Anonymous about 8 years ago

Thank you very much for resolving this issue!

Here's my feedback with 3.4.0beta8 on Ubuntu 12.04 x64:

- Empty column is added on the right, which makes resizing the date column much easier. Thanks!

- However, the column auto-resize feature does not seem to work. My columns in folder contents view seem to have a static width - changing the window size does not change the column width at all, meaning that columns will be hidden when the window is made smaller. Is that intended, or can old settings have something to do with it? My GTK version seems to be 2.24.10.

#5

Updated by Mark Freeman 5 months ago

Thank you so much for the bugs updates these are pretty valuable to all. I was looking for help to fix the bugs and thanks for the downloadable bugs-free files with us. Your blog updates on http://blogs.bu.edu/tylercaz/tips-to-study-smarter/ are quite acknowledging and beneficial keep going with excellent work.

#6

Updated by replica watches 2 months ago

https://www.bestwatchaaa.com/Graham-replica.html https://www.bestwatchss.com/Breitling-Replica-Watches.html https://www.watchrm.com/ inventor and https://www.replicawatchsshop.cc/Hamilton-Replica.html https://www.bestwatchaaa.com/IWC-replica.html https://www.bestwatchss.com/Rolex-Replica-Watches.html https://www.replicawatchsshop.cc/Tudor-Replica.html https://www.bestwatchss.com/Montblanc-Replica-Watches.html https://www.hotwatchsreplica.com/Franck-Muller.html first workshop https://www.hotwatchsreplica.com/tudor.html https://www.perfectwatchen.com/ https://www.hotwatchsreplica.com/Panerai.html https://www.hotwatchsreplica.com/hamilton.html https://www.hotwatchsreplica.com/emporio-armani.html https://www.hotwatchsreplica.com/Cartier.html Watch</STRONG> factory, there were https://www.bestwatchaaa.com/Corum-replica.html https://www.bestwatchss.com/Bvlgari-Replica-Watches.html patented inventions https://www.replicawatchsshop.cc/Blancpain-Replica.html contributed https://www.bestwatchaaa.com/Bedat-Co-replica.html the https://www.hotwatchsreplica.com/MontBlanc.html of watch https://www.bestwatchss.com/ https://www.bestwatchaaa.com/ Jaeger LeCoultre Replica Watches is https://www.bestwatchaaa.com/Oris-replica.html https://www.hotwatchsreplica.com/Jacob-Co.html the https://www.bestwatchaaa.com/Bulgari-replica.html prestigious https://www.bestwatchaaa.com/Rolex-replica.html https://www.replicawatchsshop.cc/Omega-Replica.html watchmaking. The https://www.goodswisswatch.com/ https://www.replicawatchsshop.cc/Patek-Philippe-Replica.html https://www.bestwatchss.com/Glashutte-Replica-Watches.html <STRONG>Fake https://www.replicawatchsshop.cc/A.Lange-Sohne-Replica.html https://www.bestwatchss.com/Zenith-Replica-Watches.html Watches</STRONG> https://www.bestwatchss.com/Oris-Replica-Watches.html is https://www.hotwatchsreplica.com/Ebel.html of https://www.bestwatchss.com/Ulysse-Nardin-Replica-Watches.html https://www.bestwatchaaa.com/Raymond-Weil-replica.html watch https://www.bestwatchss.com/Nomos-Replica-Watches.html lowest price.</p>

Also available in: Atom PDF