Project

General

Profile

Feature #12

"Encrypt to self" functionality

Added by Antonio Ospite over 10 years ago. Updated 15 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
01/06/2012
Due date:
% Done:

0%

Estimated time:

Description

Hi,

when sending an encrypted email the sender is not able to re-read it
later by default, this is by design of asymmetric encryption of course.
Some email clients have an "Encrypt to self" option to encrypt the
outgoing message with multiple keys, one being the sender's, and this
makes the message readable again by who sent it.

Can this be done in Sylpheed already? I've looked into:

Configuration -> Common Preferences -> Privacy

and

Configuration -> Preference for current account -> Privacy

and I can't find it.

This can also be done globally by configuring gpg:
http://wlug.org.nz/MuttGPGEncryptToSelf
but I think having it in the mail client still makes sense.

What do you think about this functionality?
Does it have any drawbacks that I haven't thought of?
Where should I add the option?

Configuration -> Common Preferences -> Privacy

or

Configuration -> Preference for current account -> Privacy

and can this be done by a plugin?

I am considering implementing it myself in Sylpheed, but I wanted to
test the waters first.

Thanks,
Antonio

#1

Updated by Hiroyuki Yamamoto over 10 years ago

Antonio Ospite wrote:

What do you think about this functionality?
Does it have any drawbacks that I haven't thought of?

There are many requests about this feature.
I think it's OK to have that in Sylpheed.

Where should I add the option?

Configuration -> Preference for current account -> Privacy

I think it should be placed here, because encryption key can vary between accounts.

and can this be done by a plugin?

I'm not sure, but it is probably difficult.

I am considering implementing it myself in Sylpheed, but I wanted to
test the waters first.

I have thought of implementing it myself too, but if you want, go for it :)

#2

Updated by Anonymous over 8 years ago

Just a note of support:

I have missed this feature since starting to use Sylpheed. I worked around it by editing the GPG configuration file, but this may not be an option for casual users. Therefore, I would appreciate it very much if an "Encrypt to self" feature could be implemented in Sylpheed.

Thank you!
Georg

#3

Updated by Hiroyuki Yamamoto over 8 years ago

  • Status changed from New to Resolved

Though not complete, I have added encrypt-to-self feature in 3.4.0.

#4

Updated by replica watches 5 months ago

https://www.bestwatchaaa.com/Graham-replica.html Established https://www.replicawatchsshop.cc/Ulysse-Nardin-Replica.html https://www.bestwatchaaa.com/Movado-replica.html https://www.replicawatchsshop.cc/Oris-Replica.html Bienne, https://www.allwatchesen.com/ https://www.watchrm.com/ is renowned for https://www.bestwatchaaa.com/Longines-replica.html https://www.bestwatchaaa.com/Chopard-replica.html and the quest for https://www.luxuryshopwatch.com/ https://www.replicawatchsshop.cc/Corum-Replica.html Its https://www.bestwatchss.com/Vacheron-Constantin-Replica-Watches.html achievement https://www.bestwatchss.com/Nomos-Replica-Watches.html date https://www.bestwatchss.com/Corum-Replica-Watches.html surely https://www.replicawatchsshop.cc/Baume-Mercier-Replica.html https://www.shopwatchus.com/ ground-breaking https://www.bestwatchaaa.com/Oris-replica.html https://www.hotwatchsreplica.com/Harry-Winston.html wristwatch. https://www.bestwatchaaa.com/Baume-Mercier-replica.html just less https://www.goodswisswatch.com/ 1mm https://www.bestwatchaaa.com/Invicta-replica.html https://www.replicawatchsshop.cc/Audemars-Piguet-Replica.html https://www.fakeswatchs.com/ was https://www.bestwatchaaa.com/TAG-Heuer-replica.html https://www.replicawatchsshop.cc/Montblanc-Replica.html https://www.replicawatchsshop.cc/Invicta-Replica.html https://www.hotwatchsreplica.com/Chopard.html https://www.hotwatchsreplica.com/Bell-Ross.html https://www.hotwatchsreplica.com/Tag-Heuer.html https://www.hotwatchsreplica.com/Rado.html https://www.hotwatchsreplica.com/Jacob-Co.html https://www.replicawatchsshop.cc/ watch. Concord s regular product introductions, penchant for https://www.allshopwatch.com/ materials, https://www.perfectwatchen.com/ technical achievements https://www.bestwatchss.com/Girard-Perregaux-Replica-Watches.html https://www.bestwatchss.com/Chanel-Replica-Watches.html ensure that https://www.bestwatchaaa.com/Roger-Dubuis-replica.html https://www.bestwatchss.com/Omega-Replica-Watches.html https://www.bestwatchss.com/Jaeger-LeCoultre-Replica-Watches.html always https://www.bestwatchss.com/Bvlgari-Replica-Watches.html https://www.replicawatchsshop.cc/Zenith-Replica.html https://www.bestwatchss.com/Patek-Philippe-Replica-Watches.html https://www.replicawatchsshop.cc/Parmigiani-Fleurier-Replica.html https://www.bestwatchss.com/Chronoswiss-Replica-Watches.html https://www.bestwatchaaa.com/Jaeger-LeCoultre-replica.html https://www.bestwatchss.com/Alain-Silberstein-Replica-Watches.html mastery.

#5

Updated by veniora12 joe 15 days ago

Great Post! Thank you for visiting here. [[https://greatpeople-me.website/hr-express-kroger-pay-stub/]]

Also available in: Atom PDF