Statistics
| Revision:

root / INSTALL @ 3243

History | View | Annotate | Download (5.47 KB)

1
Installation
2
============
3

    
4
This program requires GTK+ 2.4.0 or later to be compiled (GTK+ 2.6.0 or later
5
is recommended).
6

    
7
This program is developed on Ubuntu 8.04 LTS / 10.04 LTS / Windows XP.
8
It is possible that it dosen't work correctly on other environments.
9

    
10
Curretnly it is confirmed to work on the following environments
11
(Note: they might not work with the latest version):
12

    
13
Linux
14

    
15
o Ubuntu 12.04 LTS (development environment)
16
o Ubuntu 11.10
17
o Ubuntu 10.04 LTS (development environment)
18
o Ubuntu 9.04 / 9.10
19
o Ubuntu 8.04 LTS (Hardy Heron) (glibc 2.7) (development environment)
20
o Ubuntu 7.04 (Feisty Fawn) (glibc 2.5)
21
o Ubuntu 6.10 (Edgy Eft) (glibc 2.4)
22
o Debian GNU/Linux (i386/sid) (glibc 2.3.6)
23
o Debian GNU/Linux (amd64/sid-based) (glibc 2.3.5)
24
o Debian GNU/Linux (squeeze)
25
o Debian GNU/Linux 5.0 (lenny)
26
o Debian GNU/Linux 3.1 (sarge) (glibc 2.3.2)
27
o Debian GNU/Linux 3.0 (woody) (glibc 2.2.5)
28
o Debian GNU/Linux 2.2 (potato) (glibc 2.1.3)
29
o Fedora 11 / 12
30
o Fedora Core 2 / 3
31
o Red Hat Enterprise Linux 4 / 5
32
o RedHat Linux 5.2 (glibc 2.0.7)
33
o RedHat Linux 6.0
34
o RedHat Linux 6.1 + Helix GNOME (glibc 2.1.x)
35
o RedHat Linux 6.2 / 6.2J (glibc 2.1.x)
36
o RedHat Linux 7.0 / 7.0J / 7.1 / 7.2 / 7.3 / 8.0 / 9.0
37
o Vine Linux 1.1 (glibc 2.0.x + libwcsmbs)
38
o Vine Linux 2.0 (glibc 2.1.x) (Intel, PPC)
39
o Vine Linux 2.1 / 2.1.5 / 2.5 / 2.6 / 3.0
40
o Vine Linux 4.2CR / 5.0 / 5.1
41
o TurboLinux 4.0 (glibc 2.0.7 + libwcsmbs)
42
o TurboLinux 6.0 (glibc 2.1.2)
43
o TurboLinux 7.0 (glibc 2.2.x)
44
o Miracle Linux Standard Edition Version1.0
45
o Miracle Linux for PostgreSQL Version1.0
46
o Miracle Linux for Samba Version1.0
47
o Laser5 Linux 6.0 / 6.2 / 6.4 (glibc 2.1.x)
48
o Kondara MNU/Linux 1.0 (glibc 2.1.x) / 1.2 / 2.0
49
o Momonga Linux 6.1 / dev
50
o LinuxPPC2000 + Yukikaze (Japanization kit)
51
o Linux2000G (Intel / PPC)
52
o HOLON Linux 2.0 (Intel / PPC)
53
o Linux for PPC Japanese Edition 2.0 (glibc 2.1.x)
54
o Linux for PPC Japanese Edition 3.0 (glibc 2.1.x)
55
o LinuxPPC Q4 2000 (glibc 2.1.x)
56
o Linux MLD4/5
57
o Plamo Linux 2.0 / 2.1 / 2.2.x / 3.0
58
o Slackware 7.0 / 7.1 / 8.0 / 8.1 / 9.0 / 10.0 / 12.2 / 13.0
59
o Mandrake Linux 7.0 / 7.1 / 7.2 / 8.0 / 8.1 / 9.0 / 9.1 / 10.0
60
o Mandriva 2008.0 / 2008.1 / 2009.0 / 2009.1 / 2010.0 / 2010.1
61
o SuSE Linux 6.3 (glibc 2.1.2) / 6.4
62
o SuSE Linux 7.0 / 7.1 / 7.2 / 7.3 / 8.0 / 8.1 / 8.2
63
o OpenSUSE 11.1 / 11.2
64
o OpenLinux 2.3 (glibc 2.1.1 -> 2.1.3)
65
o Caldera OpenDesktop 2.4
66
o Caldera Workstation 3.1
67
o Conectiva Linux 4.0 / 5.0 / 7.0 / 8.0
68
o Vector Linux 1.5
69
o Yellow Dog Linux 2.0 (glibc 2.2.1)
70
o Yellow Dog Linux 2.1 (PowerPC)
71
o ASP Linux 7.2 (glibc 2.2.4)
72
o Redmond Linux (Lycoris)
73
o Gentoo Linux 1.x / 2004.2 (i386 / amd64)
74
o Arch Linux
75
o LinuxFromScratch
76
o Pardus 2009 / Corporate2
77

    
78
BSD
79

    
80
o FreeBSD 3.2/3.4-RELEASE
81
o FreeBSD 4.0/4.1/4.2/4.3/4.4/4.5/4.6-RELEASE
82
o FreeBSD 5.3-RELEASE
83
o FreeBSD 5.0-CURRENT
84
o FreeBSD 7-STABLE / 7.1R / 7.2R
85
o FreeBSD 8.0R
86
o NetBSD 1.4.2
87
o NetBSD 1.5 + XPG4DL
88
o NetBSD 1.5.1 / 1.5.2
89
o OpenBSD 2.7 / 2.8 / 2.9 / 3.0 / 3.1 / 3.6
90
o DragonFlyBSD 2.5.1
91
o PC-BSD 8.0
92
o BSD/OS 4.0.1
93

    
94
Others
95

    
96
o OpenSolaris 2009.06
97

    
98
Other commercial Unix
99

    
100
o Solaris 2.5 / 2.5.1 / 2.6
101
o Solaris 7 / 8 / 9 / 10
102
o AIX 4.3.3
103
o IRIX 6.3 / 6.4 / 6.5 6.5.8m
104
o HP-UX 10.20 / 11.0 / 11i
105
o Tru64 Unix 5.0 (OSF1 V5.0)
106
o Mac OS X 10.1.4 (Darwin 5.4) + XDarwin (without XLocale support) + libxpg4
107
o Mac OS X 10.2.3 (Darwin 6.3) + Apple X11 PublicBeta 0.1 + XLocale fix patch
108
o Mac OS X 10.3 / 10.4 + X11 for Mac OS X
109

    
110
Windows
111

    
112
o Windows XP / Vista / 7 / 8 (MinGW 32bit)
113

    
114
Build it
115
========
116

    
117
Please make sure that gtk-devel and glib-devel (or similar) packages are
118
installed before the compilation (you may also require flex (lex) and bison
119
(yacc)).
120

    
121
To compile and install, just type:
122

    
123
% ./configure
124
% make
125
% su
126
Password: [Enter password]
127
# make install
128

    
129
Additional libraries
130
====================
131

    
132
Compface library is required for X-Face support.
133
You can get compface utilities and library from the following location:
134

    
135
  http://freshmeat.net/projects/compface/
136

    
137
GnuPG (>= 1.2.0) and GPGME (>= 1.0.0) are required for GnuPG (PGP) support.
138
You can get GnuPG and GPGME from the following location:
139

    
140
  ftp://ftp.gnupg.org/gcrypt/gpgme/
141
  ftp://ftp.gnupg.org/gcrypt/gnupg/
142

    
143
GtkSpell is required for spell checking feature.
144

    
145
  http://gtkspell.sourceforge.net/
146

    
147
OpenSSL is required for SSL support.
148

    
149
  http://www.openssl.org/
150

    
151
Pilot-link is required for JPilot support.
152

    
153
  http://www.pilot-link.org/
154

    
155
OpenLDAP library is required for LDAP support.
156

    
157
  http://www.openldap.org/
158

    
159
Update check feature requires Curl command.
160

    
161
  http://curl.haxx.se/
162

    
163
Options for configure script
164
============================
165

    
166
  --disable-gpgme        disable GnuPG support (requires GPGME and GnuPG)
167
  --disable-ssl          disable SSL support (requires OpenSSL)
168
  --disable-compface     disable compface (X-Face) support
169
  --disable-gtkspell     disable spell checking feature (requires GtkSpell)
170
  --disable-threads      disable multi-threading support
171
  --disable-ipv6         disable IPv6 support
172
  --disable-updatecheck  disable update check feature
173
                         (updatecheckplugin will also be disabled)
174
  --disable-updatecheckplugin
175
                         disable plug-in update check feature
176
  --enable-jpilot        enable JPilot support
177
  --enable-ldap          enable LDAP support
178
  --enable-oniguruma     use Oniguruma instead of system's regex
179

    
180
For other options, refer to ./configure --help .
181

    
182

    
183
If the installation of Sylpheed failed, check whether all the required
184
libraries are correctly installed. If it still failed, please send bug
185
report to:
186

    
187
  Hiroyuki Yamamoto <hiro-y@kcn.ne.jp>