Statistics
| Revision:

root / INSTALL @ 1

History | View | Annotate | Download (4.22 KB)

1
Installation
2
============
3

    
4
This program requires GTK+ 1.2.6 or higher to be compiled.
5

    
6
This program is developed on Debian GNU/Linux (woody/sid)
7
(Linux 2.4.x + glibc 2.2), so it is possible not to work correctly
8
on the other environment.
9

    
10
It is confirmed to work on the following environments:
11

    
12
Linux
13

    
14
o Debian GNU/Linux (i386/sid) (glibc 2.3.2) (development environment)
15
o Debian GNU/Linux (amd64/sid-based) (glibc 2.3.2) (development environment #2)
16
o Debian GNU/Linux 3.0 (woody) (glibc 2.2.5)
17
o Debian GNU/Linux 2.2 (potato) (glibc 2.1.3)
18
o Fedora Core 2 / 3
19
o RedHat Linux 5.2 (glibc 2.0.7)
20
o RedHat Linux 6.0
21
o RedHat Linux 6.1 + Helix GNOME (glibc 2.1.x)
22
o RedHat Linux 6.2 / 6.2J (glibc 2.1.x)
23
o RedHat Linux 7.0 / 7.0J / 7.1 / 7.2 / 7.3 / 8.0 / 9.0
24
o Vine Linux 1.1 (glibc 2.0.x + libwcsmbs)
25
o Vine Linux 2.0 (glibc 2.1.x) (Intel, PPC)
26
o Vine Linux 2.1 / 2.1.5 / 2.5 / 2.6 / 3.0
27
o TurboLinux 4.0 (glibc 2.0.7 + libwcsmbs)
28
o TurboLinux 6.0 (glibc 2.1.2)
29
o TurboLinux 7.0 (glibc 2.2.x)
30
o Miracle Linux Standard Edition Version1.0
31
o Miracle Linux for PostgreSQL Version1.0
32
o Miracle Linux for Samba Version1.0
33
o Laser5 Linux 6.0 / 6.2 / 6.4 (glibc 2.1.x)
34
o Kondara MNU/Linux 1.0 (glibc 2.1.x) / 1.2 / 2.0
35
o LinuxPPC2000 + Yukikaze(Japanization kit)
36
o Linux2000G (Intel / PPC)
37
o HOLON Linux 2.0 (Intel / PPC)
38
o Linux for PPC Japanese Edition 2.0 (glibc 2.1.x)
39
o Linux for PPC Japanese Edition 3.0 (glibc 2.1.x)
40
o LinuxPPC Q4 2000 (glibc 2.1.x)
41
o Linux MLD4/5
42
o Plamo Linux 2.0 / 2.1 / 2.2.x / 3.0
43
o Slackware 7.0 / 7.1 / 8.0 / 8.1 / 9.0 / 10.0
44
o Mandrake Linux 7.0 / 7.1 / 7.2 / 8.0 / 8.1 / 9.0 / 9.1 / 10.0
45
o SuSE Linux 6.3 (glibc 2.1.2) / 6.4
46
o SuSE Linux 7.0 / 7.1 / 7.2 / 7.3 / 8.0 / 8.1 / 8.2
47
o OpenLinux 2.3 (glibc 2.1.1 -> 2.1.3)
48
o Caldera OpenDesktop 2.4
49
o Caldera Workstation 3.1
50
o Conectiva Linux 4.0 / 5.0 / 7.0 / 8.0
51
o Vector Linux 1.5
52
o Yellow Dog Linux 2.0 (glibc 2.2.1)
53
o Yellow Dog Linux 2.1 (PowerPC)
54
o ASP Linux 7.2 (glibc 2.2.4)
55
o Redmond Linux (Lycoris)
56
o Gentoo Linux 1.x / 2004.2 (i386 / amd64)
57

    
58
BSD
59

    
60
o FreeBSD 3.2/3.4-RELEASE
61
o FreeBSD 4.0/4.1/4.2/4.3/4.4/4.5/4.6-RELEASE
62
o FreeBSD 5.3-RELEASE
63
o FreeBSD 5.0-CURRENT
64
o NetBSD 1.4.2
65
o NetBSD 1.5 + XPG4DL
66
o NetBSD 1.5.1 / 1.5.2
67
o OpenBSD 2.7 / 2.8 / 2.9 / 3.0 / 3.1 / 3.6
68
o BSD/OS 4.0.1
69

    
70
Other commercial Unix
71

    
72
o Solaris 2.5 / 2.5.1 / 2.6
73
o Solaris 7 / 8 / 9
74
o AIX 4.3.3
75
o IRIX 6.3 / 6.4 / 6.5 6.5.8m
76
o HP-UX 10.20 / 11.0 / 11i
77
o Tru64 Unix 5.0 (OSF1 V5.0)
78
o Mac OS X 10.1.4 (Darwin 5.4) + XDarwin (without XLocale support) + libxpg4
79
o Mac OS X 10.2.3 (Darwin 6.3) + Apple X11 PublicBeta 0.1 + XLocale fix patch
80
o Mac OS X 10.3 + X11 for Mac OS X
81

    
82
Others
83

    
84
o Windows (MSVC + GTK+ for win32) (in progress)
85

    
86
Build it
87
========
88

    
89
Please make sure that gtk-devel and glib-devel (or similar) packages are
90
installed before the compilation (you may also require flex (lex) and bison
91
(yacc)).
92

    
93
To compile and install, just type:
94

    
95
% ./configure
96
% make
97
% su
98
Password: [Enter password]
99
# make install
100

    
101
Additional libraries
102
====================
103

    
104
It is recommend to install gdk-pixbuf or gdk_imlib library before installing
105
Sylpheed for built-in image view support, and compface library for X-Face
106
support.
107

    
108
You can get compface utilities and library from the following location:
109

    
110
  http://freshmeat.net/projects/compface/
111

    
112
Sylpheed supports US-ASCII, ISO-8859-1, and EUC-JP by default.
113
If your system supports iconv() API, other character set / encoding
114
(such as UTF-8, KOI8-R, and GB2312) will be also supported.
115

    
116
GnuPG (>= 1.2.0) and GPGME (>= 0.3.10) are required for GnuPG (PGP) support
117
(GPGME 0.4.x is not supported yet).
118

    
119
You can get GnuPG and GPGME from the following location:
120

    
121
  ftp://ftp.gnupg.org/pub/gcrypt/alpha/gpgme/
122
  ftp://ftp.gnupg.org/pub/gcrypt/gnupg/
123

    
124
Options for configure script
125
============================
126

    
127
  --disable-compface  disable compface (X-Face) support
128
  --disable-ipv6      disable IPv6 support
129
  --enable-ssl        SSL support (requires OpenSSL)
130
  --enable-gpgme      GnuPG support (requires GPGME and GnuPG)
131
  --enable-ldap       LDAP support
132
  --enable-jpilot     JPilot support
133

    
134
For other options, refer to ./configure --help .
135

    
136

    
137
If the installation of Sylpheed failed, check whether all the required
138
libraries are correctly installed. If it still failed, please send bug
139
report to:
140

    
141
  Hiroyuki Yamamoto <hiro-y@kcn.ne.jp>