Bug #13

System Icon issue when ran on Windows 7

Added by Bryan Kirk almost 3 years ago. Updated 4 months ago.

Status:ClosedStart date:01/08/2012
Priority:NormalDue date:
Assignee:Bryan Kirk% Done:

0%

Category:WindowsSpent time:-
Target version:3.5

Description

When running the latest beta of Sylpheed on Windows 7, the System Tray Icon isn't in the same position as it was the last time it was running.

History

#1 Updated by Bryan Kirk almost 3 years ago

So, is this issue fixable or not?

#2 Updated by Hiroyuki Yamamoto almost 3 years ago

This problem has been confirmed, but it doesn't seem to be easily fixable for now.
I want to know technically how the notification area of Windows 7 distinguish tray icons.

#3 Updated by Bryan Kirk almost 3 years ago

Will this help?

http://msdn.microsoft.com/en-us/library/windows/desktop/ee330740(v=vs.85).aspx

Maybe something about its system tray icon is constantly changing, so it thinks its a new program being launched when it isn't.

#4 Updated by Bryan Kirk over 2 years ago

Any luck with fixing this issue?

#5 Updated by blueskyy blue over 2 years ago

I've been using Sylpheed for more than 2 years now. It's very responsive, the design is simplistic, and backing up emails are so very easy. I really like it. I would wish that this bug could be fixed soon...

Like Bryan, I too have a little experience in programming, and I pretty much agree with the gist of what he said. Here's my suggestions (with a little more details). When registering the tray icon, if a unique identifier is required, always use the same one (as oppose to generating a new uid everytime). Try also to ensure and double check that this uid is indeed unique.

Also, you might want to look into the program's initialization sequence. The tray icon should be initialized first, before the main bulk of the program. Check that the title bar is blank, or at least contain the default text, or the exact same string while the tray icon is loading. If the tray icon is running on a different thread (that is if it's running concurrently as the Sylpheed GUI), you might need to implement some kind of "blocking" mechanism, ie your main program's thread might have to wait for he tray to finish initializing.

Those were just some of my suggestions. I haven't been programming for a while now... I'm not really familiar with the Windows 7 APIs (architect); my little bit of experience came from the Windows XP APIs. Hope this helps, and thank you for Sylpheed.

#6 Updated by Bryan Kirk over 2 years ago

I have no experience in programming. I just searched Google for info regarding how Windows 7 deals with system tray icons.

#7 Updated by Bryan Kirk 11 months ago

This issue hasn't been fixed yet.

#8 Updated by Hiroyuki Yamamoto 11 months ago

Hello,

This bug has been fixed with newer version of GTK+, so updating included GTK+ will solve this.
(for several reasons, included GTK+ version is still 2.10.x)

https://bugzilla.gnome.org/show_bug.cgi?id=609622

It seems that Win7 uses tooltip text on tray icon creation to distinguish icons (undocumented).

#9 Updated by Bryan Kirk 11 months ago

How do I update the included GTK+?

#10 Updated by X. W. 11 months ago

@ Bryan Kirk:

Some time ago, i already created a feature request, asking Hiroyuki Yamamoto to update Sylpheed Win32 to utilize the very latest GTK+ 2 release (which currently is GTK+ 2.24.22). Unfortunately though, Sylpheed Win32 is still utilizing the very outdated GTK+ 2.10.14, which was released in 2007 :(.

But just see for yourself, see Feature #124:

http://sylpheed.sraoss.jp/redmine/issues/124

;)

#11 Updated by Bryan Kirk 11 months ago

I would stil like it if it was updated to fix this issue. That or patch the current version to fix it.

#12 Updated by blueskyy blue 11 months ago

I hope the problem's been resolved. I really don't know... was still using an older built when I read all of these, apparently I was subscribed to a couple of threads, or they were all linked to this one thread, whatever... And because of that, I decided to try my hands on compiling the latest Sylpheed stable 3.3.0 source code against the latest GTK 2.24.10 libraries on Visual Studio 2013. After 3 whole days of work, I was finally able to get it to compile satisfactorily. It seems like there wasn't a problem at all! The tray icon remembered its place after reboot. Test on Windows 7 and Windows 8.

Here's my build:
http://yunpan.cn/QDgazwfTJIcCF

I know it's slow for non-members, but it's superbly fast for registered user (which btw is free), and they give away practically unlimited amount of free space, so I used it for all my backup needs. I've also attached it to the post if that works.

Note however, that this is just a TEST build! I've also removed GPGme because I can't seem to find a library that would work nicely with Visual Studio. Sylpheed is an awesome software! Thank you Hiroyuki Yamamoto, and all other developers who have been involved!

#13 Updated by blueskyy blue 11 months ago

I hope the problem's been resolved. I really don't know... was still using an older built when I read all of these, apparently I was subscribed to a couple of threads, or they were all linked to this one thread, whatever... And because of that, I decided to try my hands on compiling the latest Sylpheed stable 3.3.0 source code against the latest GTK 2.24.10 libraries on Visual Studio 2013. After 3 whole days of work, I was finally able to get it to compile satisfactorily. It seems like there wasn't a problem at all! The tray icon remembered its place after reboot. Tested on Windows 7 and Windows 8.

Here's my build:
http://yunpan.cn/QDgazwfTJIcCF

I know it's slow for non-members, but it's superbly fast for registered user (which btw is free), and they give away practically unlimited amount of free space, so I used it for all my backup needs. I've also attached it to the post if that works.

Note however, that this is just a TEST build! I've also removed GPGme because I can't seem to find a library that would work nicely with Visual Studio. Sylpheed is an awesome software! Thank you Hiroyuki Yamamoto, and all other developers who have been involved!

Oh, forgot to mention, if you need to start Sylpheed minimized, use "--iconfied" parameter (without the quotes). I know it's not a word, I made it up.

#14 Updated by X. W. 11 months ago

@ blueskyy:

GTK+ 2.24.10 is not the latest GTK+ 2 version.

GTK+ 2.24.10 is almost two years old, see:

https://mail.gnome.org/archives/ftp-release-list/2012-February/msg00022.html

;)

The latest GTK+ 2 version currently is GTK+ 2.24.22, see:

https://mail.gnome.org/archives/ftp-release-list/2013-October/msg00017.html

;)

Anyway, thanks for your efforts.

Won't be using your build though.

Because i want an offical build, build by Hiroyuki Yamamoto ;).

So, let's hope Feature #124 will soon be realized.

#15 Updated by Kentaro HAYASHI 8 months ago

  • Status changed from New to Confirmed

#16 Updated by Bryan Kirk 5 months ago

Will this bug be fixed soon or not?

#17 Updated by X. W. 5 months ago

Bryan Kirk wrote:

Will this bug be fixed soon or not?

Just read:

http://sylpheed.sraoss.jp/redmine/issues/124#note-18

;)

#18 Updated by Hiroyuki Yamamoto 5 months ago

  • Status changed from Confirmed to In Progress

Bryan Kirk wrote:

Will this bug be fixed soon or not?

It has already been fixed in the test win32 build with GTK+ 2.24.23,
and will be available in the next beta release 3.5beta1.

Mostly because I have encountered some critical crash bugs (which I have finally fixed) for last several weeks, I didn't feel like releasing it.

Since they have been fixed (I hope), 3.5beta1 will be released in the near future (probably within next week).

#19 Updated by Bryan Kirk 4 months ago

I can confirm that it has been fixed in the latest beta.

#20 Updated by Hiroyuki Yamamoto 4 months ago

  • Category set to Windows
  • Status changed from In Progress to Closed
  • Target version set to 3.5

Marked as fixed.

Also available in: Atom PDF